سلام ، آیا این بازدید اول شماست ؟ یا
تبلیغات در این انجمن سفارش تبلیغات
نمایش نتایج: از شماره 1 تا 6 , از مجموع 6

موضوع: ارتقاء به جوملا 1.7

  1. #1

    تاریخ عضویت
    Dec 2009
    نوشته ها
    86
    تشکر
    8
    تشکر شده 3 بار در 2 ارسال

    ارتقاء به جوملا 1.7

    سلام
    چون بخشی برای جوملا 1.7 وجود نداره من سئوالم رو اینجا مطرح می کنم
    میشه در مورد این مطلب که توی ویکی گذاشتید بیشتر توضیح بدید

    بعد از انجام حذف فایل*ها و پوشه*ها، شما باید پایگاه داده را بروز رسانی کنید. برای اینکار فایل
    installation/sql/mysql/joomla_update_17ga.sql
    یا
    /administrator/components/com_admin/sql/updates/mysql/1.7.0-2011-06-06.sql
    و
    administrator/components/com_admin/sql/updates/mysql/1.7.0-2011-06-06-2.sql
    را پیدا کنید.
    در فایل*های ذکر شده در بالا کدهای زیر را جستجو کنید:



    ALTER TABLE `#__languages` ADD COLUMN `ordering` INT(11) NOT NULL DEFAULT 0 AFTER `published`; ALTER TABLE `#__languages` ADD INDEX `idx_ordering` (`ordering`);



    CREATE TABLE IF NOT EXISTS `#__associations` ( `id` VARCHAR(50) NOT NULL COMMENT 'A reference to the associated item.', `context` VARCHAR(50) NOT NULL COMMENT 'The context of the associated item.', `key` CHAR(32) NOT NULL COMMENT 'The key for the association computed from an md5 on associated ids.', PRIMARY KEY `idx_context_id` (`context`, `id`), INDEX `idx_key` (`key`) ) DEFAULT CHARSET=utf8;

    درون کدهای بالا عبارت "#__languages" و "#__associations" را پیدا کنید.
    به جای علامت پوند و زیر خط (# _) پیشوند جداول پایگاه داده خود را قرار دهید، بصورت پیش فرض 'jos' پیشوند جداول پایگاه داده می*باشد.
    اگر شما پیشوند فایل پایگاه داده را ندارید، فایل configuration.php را پیدا کرده و آنرا باز کنید و $dbprefix را جستجو کرده و عبارت مقابل آنرا که داخل کوتیشن مارک هست یادداشت کنید.
    بنابراین شما نیاز به تغییر " # __languages " به " jos_languages " دارید و همینطور بقیه فایل*ها را تغییر دهید.
    زمانیکه اینکار را انجام دادید با phpMyAdmin وارد مدیریت پایگاه داده شوید (یا هر راهی که برای ورود به مدیریت پایگاه داده استفاده می*کنید) و پایگاه داده را باز کنید. سپس به زبانه SQL بروید و آنرا باز کنید.

    فایل joomla_update_17ga.sql را ویرایش و محتوای مورد نظر را کپی کنید و بر روی دکمه Go کلیک کنید تا تغییرات اعمال شود.

    سایت شما اکنون به [مهمان/کاربر گرامی برای دیدن لینک ها ابتدا باید عضو سایت شوید و لاگین کنید برای ثبت نام اینجا کلیک کنید] 1.7 بروز شده است.
    من همچین فایلی رو توی دیتا بیسم ندارم
    joomla_update_17ga.sql

    و اگه چندتا تصویر هم میاشتید خیلی خوب میشد.
    از راه اول و دوم هم نتونستم ابدیت کنم
    توی قسمت ادمین و سایت پیغام زیر نمایش داده میشه هم وقتی که از راه اول و دوم استفاده کردم و هم راه سوم .

    قسمت ادمین
    کد:
    Warning:  require(/home/nrpkho13/domains/.com/public_html/includes/version.php) [[مهمان/کاربر گرامی برای دیدن لینک ها ابتدا باید عضو سایت شوید و لاگین کنید برای ثبت نام اینجا کلیک کنید]]: failed to open stream: No such file or directory in /home/nrpkho13/domains/.com/public_html/administrator/includes/framework.php on line 34
    
    Fatal error:  require() [[مهمان/کاربر گرامی برای دیدن لینک ها ابتدا باید عضو سایت شوید و لاگین کنید برای ثبت نام اینجا کلیک کنید]]:  Failed opening required  '/home/nrpkho13/domains/.com/public_html/includes/version.php'  (include_path='.:/usr/local/lib/php') in /home/nrpkho13/domains/.com/public_html/administrator/includes/framework.php on line 34

    این پیغام هم مال قسمت سایت هستش

    کد:
    Warning:  require_once(/home/nrpkho13/domains/.com/public_html/libraries/joomla/import.php) [[مهمان/کاربر گرامی برای دیدن لینک ها ابتدا باید عضو سایت شوید و لاگین کنید برای ثبت نام اینجا کلیک کنید]]: failed to open stream: No such file or directory in /home/nrpkho13/domains/.com/public_html/includes/framework.php on line 40
    
    Fatal error:  require_once() [[مهمان/کاربر گرامی برای دیدن لینک ها ابتدا باید عضو سایت شوید و لاگین کنید برای ثبت نام اینجا کلیک کنید]]:  Failed opening required  '/home/nrpkho13/domains/.com/public_html/libraries/joomla/import.php'  (include_path='.:/usr/local/lib/php') in /home/nrpkho13/domains/.com/public_html/includes/framework.php on line 40

    جهت مشاهده لینک ها باید ثبت نام کنید یا لاگین کنید.


  2. # ADS
    تبلیغات در جوملا فارسی
    تاریخ عضویت
    Always
    نوشته ها
    Many
     

  3. #2
    Admin
    تاریخ عضویت
    May 2008
    محل سکونت
    I.R.IRAN
    نوشته ها
    2,630
    تشکر
    721
    تشکر شده 1,287 بار در 853 ارسال
    سلام

    بسته استیبل جوملا 1.7 رو ببینید

    installation/sql/mysql/joomla_update_17ga.sql

    این آموزش مربوط به قبل از انتشار رسمی نسخه استیبل بود.

    آموزش در دانشنامه جوملا فارسی به روز خواهد شد.

    چنانچه از جوملا نسخه 1.6.5 جوملا فارسی استفاده می کنید پیشنهاد می کنیم تا انتشار نسخه جوملا 1.7 فارسی صبر کنید.

    در پناه حق
    ویرایش توسط hamidy : 07-20-2011 در ساعت 11:03 AM

    جهت مشاهده لینک ها باید ثبت نام کنید یا لاگین کنید.


  4. #3
    Admin
    تاریخ عضویت
    May 2008
    محل سکونت
    I.R.IRAN
    نوشته ها
    2,630
    تشکر
    721
    تشکر شده 1,287 بار در 853 ارسال
    سلام

    [مهمان/کاربر گرامی برای دیدن لینک ها ابتدا باید عضو سایت شوید و لاگین کنید برای ثبت نام اینجا کلیک کنید] به روز شد.

    مجدد بر اساس آموزش ارتقا را انجام دهید.

    در پناه حق

    جهت مشاهده لینک ها باید ثبت نام کنید یا لاگین کنید.


  5. #4

    تاریخ عضویت
    Dec 2009
    نوشته ها
    86
    تشکر
    8
    تشکر شده 3 بار در 2 ارسال
    واسه دو قسمت اول کارتون خیلی خوب بود ولی قسمت سوم همون قبلیه و نه تصویری اضافه شده و نه چیزی بیشتری گفتید.
    من با دو قسمت اول مشکل دارم .در قسمت اول وقتی گزینه جوملا1.7 رو پیدا می کنم و اپدیت رو میزنم بعد از چند دقیقه یه پیغام Error میده و میگه برگردید به کنترل پنل اصلی و وقتی بر می گردم توی سایت و ادمین با پیغامهایی که توی پست اول گذاشتم مواجه میشم
    ممنون میشم یشتر راهنمایی کنید.

    جهت مشاهده لینک ها باید ثبت نام کنید یا لاگین کنید.


  6. #5
    Admin
    تاریخ عضویت
    May 2008
    محل سکونت
    I.R.IRAN
    نوشته ها
    2,630
    تشکر
    721
    تشکر شده 1,287 بار در 853 ارسال
    سلام

    واسه دو قسمت اول کارتون خیلی خوب بود
    ممنون که مفید واقع شد.

    ولی قسمت سوم همون قبلیه و نه تصویری اضافه شده و نه چیزی بیشتری گفتید.
    بنا نیست تصویری اضافه بشه. شما باید ارتقاء رو به روش دستی یعنی اینکه همه کارهایی که ویزارد ارتقا انجام می ده ، شما باید خودتون انجام بدید.

    در پناه حق

    جهت مشاهده لینک ها باید ثبت نام کنید یا لاگین کنید.


  7. #6

    تاریخ عضویت
    Dec 2009
    نوشته ها
    86
    تشکر
    8
    تشکر شده 3 بار در 2 ارسال
    من که گفتم از طریق دو روش اول مشکل دارم همیشه هم مشکل بوده از وقتی جوملا 1.6 رو نصب کردم نتونستم از طریق گزینه آپدیت اونو اپدیت کنم و همیشه به صورت دستی اینکار رو می کردم حالا سوالم اینه که موقع اپدیت از طریق خود مدیریت جوملا باید سطح دسترسی پوشه یا فایلی رو تغییر بدم و یا کار خاصی نیاز هست.

    دوم اینکه مشکل چیه که این پیغامها رو میده؟


    قسمت ادمین

    Warning: require(/home/nrpkho13/domains/.com/public_html/includes/version.php) [[مهمان/کاربر گرامی برای دیدن لینک ها ابتدا باید عضو سایت شوید و لاگین کنید برای ثبت نام اینجا کلیک کنید]]: failed to open stream: No such file or directory in /home/nrpkho13/domains/.com/public_html/administrator/includes/framework.php on line 34 Fatal error: require() [[مهمان/کاربر گرامی برای دیدن لینک ها ابتدا باید عضو سایت شوید و لاگین کنید برای ثبت نام اینجا کلیک کنید]]: Failed opening required '/home/nrpkho13/domains/.com/public_html/includes/version.php' (include_path='.:/usr/local/lib/php') in /home/nrpkho13/domains/.com/public_html/administrator/includes/framework.php on line 34
    قسمت سایت
    Warning: require_once(/home/nrpkho13/domains/.com/public_html/libraries/joomla/import.php) [[مهمان/کاربر گرامی برای دیدن لینک ها ابتدا باید عضو سایت شوید و لاگین کنید برای ثبت نام اینجا کلیک کنید]]: failed to open stream: No such file or directory in /home/nrpkho13/domains/.com/public_html/includes/framework.php on line 40 Fatal error: require_once() [[مهمان/کاربر گرامی برای دیدن لینک ها ابتدا باید عضو سایت شوید و لاگین کنید برای ثبت نام اینجا کلیک کنید]]: Failed opening required '/home/nrpkho13/domains/.com/public_html/libraries/joomla/import.php' (include_path='.:/usr/local/lib/php') in /home/nrpkho13/domains/.com/public_html/includes/framework.php on line 40
    من واقعاً نمیدونم این فایل joomla_update_17ga.sql رو باید چکار کنم باید توی دیتابیس اپلود کنم یا چی؟
    ممنون میشم در این مورد هم راهنمایی دقیق بکنید.

    جهت مشاهده لینک ها باید ثبت نام کنید یا لاگین کنید.


موضوعات مشابه

  1. نحوه ارتقاء پارس جوملا 1.5.14 به جوملا مامبولرن 1.5.22
    توسط p30p30 در انجمن نصب جوملا 1.5 فارسی
    پاسخ ها: 2
    آخرين نوشته: 11-19-2010, 07:02 PM
  2. مشکل در ارتقاء جوملا از ورژن Joomla! 1.0.13 Stable به آخرین نسخه
    توسط sattari در انجمن ارتقاء به جوملا 1.5 فارسی
    پاسخ ها: 2
    آخرين نوشته: 04-26-2010, 09:42 AM
  3. چگونگی ارتقاء جوملا 1.5.10 فارسی به 1.5.15 بدونه اشکال
    توسط ehsan.t در انجمن ارتقاء به جوملا 1.5 فارسی
    پاسخ ها: 7
    آخرين نوشته: 03-23-2010, 04:49 PM
  4. ارتقاء پارس جوملا
    توسط ehsa2009 در انجمن ارتقاء به جوملا 1.5 فارسی
    پاسخ ها: 3
    آخرين نوشته: 10-31-2009, 05:49 PM
  5. ارتقاء از مامبو 4.5.2.3 به جوملا
    توسط baharlou در انجمن ارتقاء مامبو فارسی
    پاسخ ها: 8
    آخرين نوشته: 04-05-2006, 12:19 AM

علاقه مندی ها (Bookmarks)

علاقه مندی ها (Bookmarks)

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •